3180 views
# MNT ZZ9000 Batch 1-4 1V8/3V3 Short Fix Published by: MNT Research GmbH, Berlin. Last updated: 2020-08-11 ## What's the problem? MNT ZZ9000s revision R-1 and R-2 have a design error that shorts the 1V8 and 3V3 supply voltage rails of the ZYNQ module together by a wrongly connected pin on connector U12 (pin number 93). The pin is documented as XADC power supply in the MYIR documentation, but it is not specified that it is already internally connected to 1V8. This is how the mistake happened. The problem is that the mistake leads to various supply and I/O voltages connected to the ZYNQ that are specified at maximum ~1.9V are now supplied with 3.3V. This makes the ZYNQ run almost 10 degrees celsius hotter than it should, and will potentially damage the ZYNQ over a longer time. ## What about ZZ9000 R-3? If you have ZZ9000 R-3 from Batch 5 or later (to be shipped in August/September 2020), you don't need to worry. The problem is already fixed. ## Overview of ZZ9000 PCB layers Copper fills are switched off in this view. ![](https://notes.mnt.re/uploads/upload_cce3fb7ebbb60f438f873e22cc286c2e.png) Zooming into connector U12 (top connector): ![](https://notes.mnt.re/uploads/upload_bc1ad23ae3616290988b6903750175cc.png) Close-up of pin 93 connected to 3V3 by mistake: ![](https://notes.mnt.re/uploads/upload_42cbd26aa830c074537404df859ef009.png) ## Fixing Methods There are at least two known alternatives for disconnecting the 3V3 trace from pin 93 of U12. The first step is always to unplug the ZYNQ module. Then, _either_: 1. Cut and remove a part of the trace with a box cutter or razor directly in front of the pin 93 of U12. This is indicated by "CUT" in the following graphic. You will need some sort of magnification lens or (cheap) microscope for this. 2. Drill a hole with a ~1mm bit through the PCB at the location indicated by the X. The easiest way to find the right place without a template is to count the pins of U17 and U9 on the back. This is indicated by "DRILL" in the following graphic. If you drilled the hole, make sure to remove any coppper debris in it. ZZ9000 is a four-layer board with internal copper fills. You want to make sure that 3V3 is not shorted to GND inside of your brand new hole. (Check the end of this document for hints on this). ![](https://notes.mnt.re/uploads/upload_c215e6171d268d83b096eb02c882be1a.png) ## Photo of where to Cut Trace (Method 1) ![](https://notes.mnt.re/uploads/upload_9875bd673f3573977d99016ab0b0831c.jpg) Thanks to Chucky! ## Photos of Applied Hole (Method 2) ![](https://notes.mnt.re/uploads/upload_cd89845279008a762f25ba4277be4386.jpeg) ![](https://notes.mnt.re/uploads/upload_1212ad435d6f787d9472dcb5299758d3.jpeg) ![](https://notes.mnt.re/uploads/upload_5f486989cf8d84b126758e40766560c8.jpeg) ![](https://notes.mnt.re/uploads/upload_1d54a548add6aec054272bc7f61081eb.jpeg) ## Technical Drawing of Trace/Hole Location Top view of card: ![](https://notes.mnt.re/uploads/upload_9d26f10ec4bac514e6146cad93ce8b19.png) ![](https://notes.mnt.re/uploads/upload_5d06002c0a90a0c76e561cf7522aea86.png) ## How do I know it worked? To confirm the successful fix, you need a multimeter in continuity mode / beeper and measure if 1V8 and 3V3 are still connected. First, plug the ZYNQ module back in, or you won't be able to check for the fix! If the fix is applied, 1V8 and 3V3 rails should not be connected with the ZYNQ module plugged in (no beep). An easy location to check are the south pins of C55 (3V3) and C53 (1V8): ![](https://notes.mnt.re/uploads/upload_32dda82c26a071c6ce7d9f29d52b64d9.png) Also, you should check that neither 3V3 nor 1V8 are now shorted to GND (for example by copper debris in the hole). You can do that by checking continuity _across_ the pins of capacitors C53 and C55 each.